7.2. Konqueror als Datei-Manager

Konqueror ist Webbrowser, Datei-Manager sowie Dokumenten- und Bildbetrachter in einem. In diesem Abschnitt wird die Funktion von Konqueror als Datei-Manager beschrieben. Wenn Sie wissen möchten, wie Konqueror als Webbrowser funktioniert, lesen Sie Kapitel 3, Webbrowser Konqueror (↑Referenz).

Konqueror starten Sie über das Haussymbol in der Kontrollleiste oder mit der Tastenkombination Alt-F2 und dem Befehl konqueror $HOME. Nach dem Start wird standardmäßig der Inhalt Ihres Home-Verzeichnisses angezeigt. Das Fenster des Datei-Managers gliedert sich in folgende Bereiche: die Menüleiste am oberen Rand, darunter die Symbolleiste gefolgt von der Adressleiste. Der untere Teil des Fensters teilt sich vertikal in den Navigationsbereich und das Hauptfenster, das den Inhalt des im Navigationsbereich ausgewählten Elements anzeigt.

Abbildung 7.1. Der Datei-Manager Konqueror

Der Datei-Manager Konqueror

7.2.1. Dateivorschau

Konqueror kann bestimmte Dateien in einer Vorschau anzeigen. Normalerweise ist die Vorschau bei der Durchsicht von Verzeichnissen eingeschaltet. Sie funktioniert allerdings nur, wenn die Symbolansicht (View (Ansicht)+View Mode (Ansichtsmodus)) aktiviert ist. Die Vorschau kann Ihre tägliche Arbeit erleichtern. In großen Verzeichnissen gibt Sie Ihnen einen groben Überblick über den Inhalt der Dateien. In manchen Fällen, zum Beispiel bei komprimierten Dateien, ist die Vorschau nicht von Nutzen. Wenn Sie den Mauszeiger aber auf eine solche Datei setzen, wird eine Quickinfo mit Informationen wie Name, Benutzer und Größe der Datei eingeblendet.

Sie können einstellen, zu welchen Dateien eine Vorschau angezeigt wird. Wählen Sie dazu Einstellungen+Configure Konqueror (Konqueror konfigurieren) und öffnen Sie den Bereich Previews (Vorschauen) & Meta-Data (Metadaten). Konqueror unterscheidet zwischen Internet- und lokalen Protokollen. Jedes Protokoll kann gesondert aktiviert werden. Bestätigen Sie Ihre Einstellungen danach mit OK.

7.2.2. Dateizuordnungen

Ein modernes Desktop-System sollte wissen, wie es Dateitypen handhabt. In Konqueror können Sie selbst festlegen, welche Anwendungen zur Verarbeitung bestimmter Dateitypen verwendet werden. Wählen Sie dazu Einstellungen+Configure Konqueror (Konqueror konfigurieren) und öffnen Sie den Bereich Dateizuordnungen. Wenn Sie eine bestimmte Dateinamenserweiterung suchen, verwenden Sie das Feld Find filename pattern (Dateinamenmuster suchen). In der Liste werden dann nur Dateitypen mit übereinstimmendem Dateinamensmuster angezeigt.

Möchten Sie zum Beispiel die Anwendung für die Wiedergabe von MP3-Dateien ändern, geben Sie mp3 ein. Daraufhin wird der Eintrag x-mp3 angezeigt. Klicken Sie auf diesen Eintrag, um rechts daneben ein Einstellungsdialogfeld zu diesem Dateityp zu öffnen. In diesem Dialogfeld können Sie das Symbol, die Dateinamensmuster, die Beschreibung und die Reihenfolge der Anwendungen ändern. Falls die von Ihnen gewünschte Anwendung nicht aufgelistet ist, klicken Sie auf Hinzufügen und geben Sie den Anwendungsbefehl ein. Gelegentlich entspricht die Reihenfolge der Listeneinträge nicht Ihren Vorstellungen. In diesem Fall können Sie einzelne Anwendungen verschieben, indem Sie darauf klicken und ihnen mit Nach oben oder Nach unten eine höhere oder niedrigere Priorität zuteilen. Standardmäßig wird die an oberster Stelle der Liste genannte Anwendung geöffnet, wenn Sie in Konqueror auf eine Datei dieses Dateityps klicken.

Eventuell sind einige von Ihnen benötigte Dateitypen nicht in dieser Liste aufgeführt. Klicken Sie in diesem Fall auf Hinzufügen, um ein Dialogfeld zu öffnen, in dem Sie zunächst eine Gruppe auswählen und danach den gewünschten Dateityp eingeben. Die Gruppe bestimmt den übergeordneten Typ der Datei, zum Beispiel Audio, Bild, Text oder Video. In der Regel lassen sich alle Dateitypen in eine dieser Klassifizierungen einteilen. Geben Sie danach unter Type name (Name des Dateityps) den Namen des neuen Dateityps ein. Nach der Bestätigung mit OK können Sie die zugehörigen Dateinamenserweiterungen eingeben. Geben Sie im Textfeld eine Beschreibung ein und legen Sie die Anwendung fest, die diesem Dateityp zugewiesen werden soll. Bestätigen Sie Ihre Einstellungen danach mit OK.

7.2.3. Das Konqueror-Menü

Location (Adresse)

Über Location (Adresse) können Sie weitere Konqueror-Fenster öffnen. New Window (Neues Fenster) öffnet Ihr Home-Verzeichnis in einem neuen Fenster. Duplicate Window (Fenster duplizieren) öffnet ein zweites Fenster mit dem gleichen Inhalt wie das erste Fenster. Mit der Browserfunktion können Sie auch eine Datei oder einen Link via Email versenden. Jeder dieser Menüeinträge ruft den KMail-Composer auf. Dort brauchen Sie nur noch den Empfänger anzugeben und den Text zu verfassen. Die Datei ist bereits an die Email-Nachricht angehängt, ein Link wäre im Email-Text eingefügt. Außerdem können Sie direkt aus dem Menü drucken.

Bearbeiten

Die meisten Optionen im Menü Bearbeiten werden erst dann aktiv, wenn Sie ein Element im Hauptfenster ausgewählt haben. Neben den Standardeditierfunktionen wie Ausschneiden, Kopieren, Einfügen, Umbenennen, Verschieben in den Papierkorb und Löschen enthält dieses Menü auch die Option Create New (Neu erstellen), mit der Sie Verzeichnisse, Dateien und Geräte erstellen können. Außerdem können Sie über dieses Menü die Eigenschaften und Berechtigungen von Dateien und Verzeichnissen anzeigen und ändern. Damit können Sie die Lese-, Schreib- und Ausführungsberechtigungen für den Eigentümer, eine Gruppe oder alle Benutzer einstellen. Mit diesem Menü können Sie auch mehrere ausgewählte Elemente gleichzeitig bearbeiten. Zur Auswahl der Elemente ziehen Sie den Mauszeiger im Hauptfenster mit gedrückter linker Maustaste über die gewünschten Elemente oder klicken Sie auf Selection (Auswahl)+Select (Auswählen).

Ansicht

Über das Menü Ansicht schalten Sie zwischen verschiedenen Ansichtsmodi um. Wenn ein Verzeichnis sehr viele Elemente enthält, empfiehlt sich eventuell die Textansicht oder auch die Baumansicht. Zur Anzeige von HTML-Seiten sollten Sie Use index.html (index.html verwenden) aktivieren. Falls ein Verzeichnis diese Datei enthält, wird sie geladen und angezeigt.

Mit den Optionen Icon Size (Symbolgröße), Show Hidden Files (Versteckte Dateien anzeigen), Sort (Sortieren) und Preview (Vorschau) stellen Sie ein, wie die Verzeichnisinhalte im Hauptfenster angezeigt werden. Mit Configure Background (Hintergrund konfigurieren) können Sie für den Hintergrund des Hauptfensters eine bestimmte Farbe oder ein Hintergrundbild auswählen.

Go (Gehe zu)

Dieses Menü enthält die Navigationsfunktionen Up (Aufwärts), Back (Zurück), Forward (Weiter) und Home Page (Startseite). Die gleichen Funktionen stehen jedoch wesentlich bequemer in der Symbolleiste zur Verfügung. Außerdem können Sie aus diesem Menü Anwendungen aufrufen und Ordner öffnen, sofern diese auch über Desktop-Symbole verfügbar sind. Im unteren Teil des Menüs befindet sich eine Liste der zuletzt angezeigten Verzeichnisse und Links.

Lesezeichen

Für häufig verwendete Internet-Adressen (URLs) und Datei- oder Verzeichnispfade auf dem Host können Sie sich Lesezeichen einrichten. Wenn Sie Add Bookmark (Lesezeichen hinzufügen) auswählen, wird der aktuelle Inhalt der Adressleiste als Lesezeichen gespeichert. Um später wieder auf diese Adresse (bzw. diesen Pfad) zurückzugreifen, klicken Sie einfach auf das Lesezeichen. Aus praktischen Gründen sollten Sie Lesezeichen in Ordnern verwalten. Der Ordner SUSE ist bereits vorhanden. Er enthält die Lesezeichen wichtiger SUSE-Webseiten. Edit Bookmarks (Lesezeichen bearbeiten) öffnet den Lesezeichen-Editor, in dem Sie Lesezeichen löschen, umbenennen und zwischen Ordnern verschieben können.

Tools (Extras)

Dieses Menü enthält diverse Funktionen wie Run Command (Befehl ausführen), Terminal Window (Terminalfenster öffnen) und Find Files (Dateien suchen). Mit View Filter (Ansichtsfilter) können Sie die Anzeige auf bestimmte Dateitypen einschränken. Wenn beispielsweise ein Verzeichnis Grafikdateien der verschiedensten Formate enthält, Sie aber nur PNG-Dateien anzeigen möchten, können Sie alle anderen Dateien mit diesem Menüeintrag ausfiltern.

Die Option Create Image Gallery (Bildergalerie erstellen) durchsucht das aktuelle Verzeichnis nach Bilddateien. Aus diesen Dateien werden Miniaturbilder erstellt, die auf einer HTML-Seite zusammengestellt werden. Die Einstellungen dieser HTML-Seite wie Schrift und Anzahl der Bilder pro Zeile können Sie zuvor in einem Dialogfeld festlegen.

Einstellungen

Im Menü Einstellungen können Sie das Aussehen und Verhalten von Konqueror einstellen. Wenn die Menüleiste nicht angezeigt werden soll, wählen Sie Hide Menubar (Menüleiste ausblenden) aus. Mit Strg-M zeigen Sie die Menüleiste wieder an. Im Untermenü Toolbars (Symbolleisten) können Sie einzelne Symbolleisten des Datei-Managers aus- und wieder einblenden.

Mithilfe von Ansichtsprofilen können Sie die Ansicht nach voreingestellten Verwendungsmustern ändern. Zwischen den verfügbaren Profilen wechseln Sie mit Load View Profile (Ansichtsprofil laden). Das Webbrowser-Profil wird im Übrigen automatisch verwendet, wenn Sie in der Kontrollleiste auf das Konqueror-Symbol klicken. Eigene Profile können Sie mit Configure View Profiles (Ansichtsprofile konfigurieren) hinzufügen. Darüber hinaus können Sie mit Configure Shortcuts (Kurzbefehle konfigurieren) individuelle Tastenkombinationen für bestimmte Aktionen festlegen, mit Configure Toolbars (Symbolleisten konfigurieren) die Symbolleiste anpassen und mit Configure Konqueror (Konqueror konfigurieren) allgemeine Einstellungen des Datei-Managers ändern.

Fenster

Über dieses Menü können Sie das Hauptfenster horizontal oder vertikal in zwei Fensterbereiche aufteilen. Darüber hinaus können Sie die Registerkarten des Hauptfensters öffnen oder schließen, duplizieren oder als separate Fenster anzeigen.

Hilfe

Über das Menü Hilfe öffnen Sie das Konqueror-Handbuch oder aktivieren Sie die Hilfefunktion What's This (Was ist das?). Diese Funktion kann in der Regel auch über das Fragezeichen rechts oben in der Titelleiste aufgerufen werden. Solange diese Hilfe aktiviert ist, ist der Mauszeiger mit einem Fragezeichen versehen. Wenn Sie mit diesem Mauszeiger auf ein Element klicken, wird ein kurzer Hilfetext eingeblendet (sofern verfügbar). Darüber hinaus bietet das Menü Hilfe eine kurze Einführung in Konqueror und die Möglichkeit, Fehler und andere Probleme an die Entwickler zu melden. About Konqueror (Info zu Konqueror) und About KDE (Info zu KDE) zeigen Informationen zur vorliegenden Version und Lizenz sowie zu den Autoren und Übersetzern des Produkts an.

7.2.4. Die Symbolleiste

Die Symbolleiste verkürzt den Zugriff auf häufig verwendete Funktionen, die auch über das Menü aufgerufen werden können. Wenn Sie den Mauszeiger eine kurze Weile über einem Symbol verweilen lassen, wird eine kurze Beschreibung zur jeweiligen Funktion angezeigt. Wenn Sie in einem freien Bereich der Symbolleiste mit der rechten Maustaste klicken, öffnet sich ein Menü, über das Sie die Position der Symbolleiste ändern, von Symbolen auf Text umschalten, die Symbolgröße ändern und einzelne Leisten ein- oder ausblenden können. Das Konfigurationsdialogfeld öffnen Sie mit Configure Toolbars (Symbolleisten konfigurieren). Auf der rechten Seite der Symbolleiste befindet sich das Konqueror-Symbol. Dieses animierte Symbol bewegt sich, so lange ein Verzeichnis oder eine Webseite geladen wird.

7.2.5. Die Adressleiste

Der Adressleiste vorangestellt ist ein schwarzes Symbol mit einem weißen X. Wenn Sie auf dieses Symbol klicken, wird der Inhalt des Adressfelds gelöscht und Sie können eine neue Adresse eingeben. Gültige Adressen sind Pfadangaben, wie die Adresse des Home-Verzeichnisses, oder die URLs von Webseiten. Drücken Sie nach der Eingabe einer Adresse die Eingabetaste oder klicken Sie auf die Schaltfläche Go (Gehe zu) rechts neben dem Eingabefeld. Verzeichnisse oder Webseiten, die Sie erst vor kurzem aufgerufen haben, können Sie über den schwarzen Pfeil rechts neben der Adressleiste schnell wieder öffnen. Dadurch ersparen Sie sich die Eingabe der vollständigen Adresse, wenn Sie dieselben Inhalte öfters anzeigen. Für Adressen, die Sie regelmäßig besuchen, empfehlen sich jedoch Lesezeichen.

7.2.6. Das Hauptfenster

Im Hauptfenster wird der Inhalt des ausgewählten Verzeichnisses angezeigt. Sobald Sie dort auf ein Symbol klicken, wird die betreffende Datei in Konqueror geöffnet oder zur weiteren Bearbeitung in die zugewiesene Anwendung geladen. Wenn Sie auf ein RPM-Paket klicken, wird dessen Inhalt angezeigt. Wählen Sie danach Installiere Paket mit YaST aus, dann werden Sie nach dem root-Passwort gefragt, damit das Paket installiert werden kann.

Wenn Sie mit der rechten Maustaste auf ein Symbol klicken, wird ein zum Dateityp passendes Menü geöffnet, über das Sie gängige Aktionen wie Ausschneiden, Kopieren, Einfügen und Löschen ausführen können. Wenn Sie Öffnen mit auswählen, können Sie die Anwendung, in der die Datei geöffnet werden soll, aus einer Liste geeigneter Programme auswählen.

Die schnellste Methode für viele Aktionen ist Drag & Drop. Dateien lassen sich zum Beispiel schnell von einem Konqueror-Fenster in ein anderes verschieben, indem Sie sie mit gedrückter linker Maustaste an die gewünschte Stelle ziehen. Danach müssen Sie nur noch angeben, ob die Dateien verschoben oder kopiert werden sollen.